Nissan Rogue Sport Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
My Forward Emergency Braking (FEB) warning light kept blinking on my way to work this morning. This happened even though I was stopped at a light, and continued as I proceeded; even without any car in front of me (nor in opposing traffic). Is anyone else experiencing this? My main concern isn’t about the notification, but I would hate if the computer took over and started braking my car when it’s not necessary.

One thought for me might be that I need to clean the sensor area where the Nissan front emblem is located, or because it’s cold outside (37F). What do you guys think? If I have time this weekend or next, I may take it to the dealer this weekend just to ask.
 

·
Registered
Joined
·
43 Posts
A good first step is to clear the sensors for sure, but if the problem persists then your computer may need to be flashed/reset. I have seen quite a few owners complaining about this issue on other forums, some were lucky enough to solve the problem by thoroughly cleaning the sensors and others have been in and out of the dealership, with no solutions found. Apparently the technicians don't even recognize the error codes the computer is putting out.
 

·
Registered
Joined
·
225 Posts
Hope yours is just a case of dirty sensors and not anything deeper, but I'm wondering if this is just a light problem or i it could prove dangerous down the road.
 

·
Registered
Joined
·
363 Posts
i think sometimes it might be the software in the sensors which in that case if you can find a way to reset them yourself, great, if not then ask the dealer.
often I like to think through these small and easy things to do first before digging into bigger tasks.
 

·
Registered
Joined
·
225 Posts
The only thing in the owner's manual is how to find the trip reset, or maybe I missed something. Best to bring it in so the technicians reset the entire system or just take a look at what codes the Rouge Sport throws up.
 

·
Registered
Joined
·
41 Posts
I experienced a solid FEB warning light yesterday on my way to my mom's house. It was raining cats and dogs, lots of dirty spray from the cars in front of me. Once I got to a less congested road, it cleared itself. I guess the rain cleaned the front of the car enough for the sensors to work again.
 

·
Registered
Joined
·
34 Posts
I got that alot during the mornings this last winter. Just seemed like when the windows had any condensation or were fogged a little I got that warning. Always happened in the morning time. If I wiped the sensors off at the commuter lot and turned the car back on the light did not come back on. I just take it as very sensitive sensors.
 
1 - 7 of 7 Posts
Top